use strict;
my $str = 'MARKET S.A.|41.355.058/0001-35| |123,45
MARKET S.A.|41.355.058/0001-35|681.538.156-01|123,45
MARKET S.A.|41.355.058/0001-35|70.092.275/0001-88|123,45';
my $regex = qr/^.*?(?:(\d{3}\.\d{3}\.\d{3}-\d{2})|(\d{2}\.\d{3}\.\d{3}\/\d{4}-\d{2}).*?((?-2))).*?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}