import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?(?:(\\d{3}\\.\\d{3}\\.\\d{3}-\\d{2})|(\\d{2}\\.\\d{3}\\.\\d{3}\\/\\d{4}-\\d{2}).*?((?-2))).*?$";
final String string = "MARKET S.A.|41.355.058/0001-35| |123,45\n\n"
+ "MARKET S.A.|41.355.058/0001-35|681.538.156-01|123,45\n\n"
+ "MARKET S.A.|41.355.058/0001-35|70.092.275/0001-88|123,45";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}