using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[а-яА-Яa-zA-Z]+";
string input = @"слова слова слова.
слова слова.
Кто в теме, подскажите как регуляркой взять одно первое слово из текста.
спасибо!
Кто в теме, подскажите как регуляркой взять одно первое слово из текста.
спасибо!
English text english text English text English text english text
english text English text English text еnglish text";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}