use strict;
my $str = 'слова слова слова.
слова слова.
Кто в теме, подскажите как регуляркой взять одно первое слово из текста.
спасибо!
Кто в теме, подскажите как регуляркой взять одно первое слово из текста.
спасибо!
English text english text English text English text english text
english text English text English text еnglish text';
my $regex = qr/^[а-яА-Яa-zA-Z]+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}