// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[а-яА-Яa-zA-Z]+").unwrap();
let string = "слова слова слова.
слова слова.
Кто в теме, подскажите как регуляркой взять одно первое слово из текста.
спасибо!
Кто в теме, подскажите как регуляркой взять одно первое слово из текста.
спасибо!
English text english text English text English text english text
english text English text English text еnglish text";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}