import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[а-яА-Яa-zA-Z]+";
final String string = "слова слова слова.\n"
+ "слова слова.\n"
+ "Кто в теме, подскажите как регуляркой взять одно первое слово из текста.\n"
+ "спасибо!\n"
+ "Кто в теме, подскажите как регуляркой взять одно первое слово из текста.\n"
+ "спасибо!\n"
+ "English text english text English text English text english text\n"
+ "english text English text English text еnglish text";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}