#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\w{2})\s*(\w{5})\s*(\w{13})\s*(\d{3})\s*(\d{7})\s*(.*?)\s*(\d{6})$"
Local $sString = "VA0017487146000066460126132202STRONG 4P 4X44G000099" & @CRLF & _
"VA 00174 8714600006646 012 6132202 STRONG 4P 4X44G 000099" & @CRLF & _
"VA001748714600006640126132202STRONG 4P 4X44G000099" & @CRLF & _
"VA 00174 871460000664 012 6132202 STRONG 4P 4X44G 000099"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")