import re
regex = re.compile(r"^(\w{2})\s*(\w{5})\s*(\w{13})\s*(\d{3})\s*(\d{7})\s*(.*?)\s*(\d{6})$", flags=re.MULTILINE)
test_str = ("VA0017487146000066460126132202STRONG 4P 4X44G000099\n"
"VA 00174 8714600006646 012 6132202 STRONG 4P 4X44G 000099\n"
"VA001748714600006640126132202STRONG 4P 4X44G000099\n"
"VA 00174 871460000664 012 6132202 STRONG 4P 4X44G 000099")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")