import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w{2})\\s*(\\w{5})\\s*(\\w{13})\\s*(\\d{3})\\s*(\\d{7})\\s*(.*?)\\s*(\\d{6})$";
final String string = "VA0017487146000066460126132202STRONG 4P 4X44G000099\n"
+ "VA 00174 8714600006646 012 6132202 STRONG 4P 4X44G 000099\n"
+ "VA001748714600006640126132202STRONG 4P 4X44G000099\n"
+ "VA 00174 871460000664 012 6132202 STRONG 4P 4X44G 000099";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}