const regex = /^(?:(?!end).)*start.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?!end).)*start.*', 'gm')
const str = `line_end; start
line start; end
`;
const subst = `*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);