re = /^(?:(?!end).)*start.*/m
str = 'line_end; start
line start; end
'
subst = '*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result