import re
regex = re.compile(r"^(?:(?!end).)*start.*", flags=re.MULTILINE)
test_str = ("line_end; start\n"
"line start; end\n")
subst = "*"
result = regex.sub(subst, test_str)
if result:
print(result)