import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http(s)?:\\/\\/.)?(www\\.)?[a-z0-9]+\\.[a-z]{2,6}\\b([-a-z0-9@:%_\\+.~#?&\\/\\/=]*)";
final String string = "ign.com\n"
+ "http://www.mywebsite.com\n"
+ "www.ign.com\n"
+ "chris@gmail.com\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}