$re = '/(http(s)?:\/\/.)?(www\.)?[a-z0-9]+\.[a-z]{2,6}\b([-a-z0-9@:%_\+.~#?&\/\/=]*)/';
$str = 'ign.com
http://www.mywebsite.com
www.ign.com
chris@gmail.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);