import re
regex = re.compile(r"(http(s)?:\/\/.)?(www\.)?[a-z0-9]+\.[a-z]{2,6}\b([-a-z0-9@:%_\+.~#?&\/\/=]*)")
test_str = ("ign.com\n"
"http://www.mywebsite.com\n"
"www.ign.com\n"
"chris@gmail.com\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")