re = /(http(s)?:\/\/.)?(www\.)?[a-z0-9]+\.[a-z]{2,6}\b([-a-z0-9@:%_\+.~#?&\/\/=]*)/
str = 'ign.com
http://www.mywebsite.com
www.ign.com
chris@gmail.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end