import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(?:.*\\-){5}).*";
final String string = "Hey-didle-didle-the-cat-and the fiddle\n"
+ "The-cow jumped over the-moon\n"
+ "How-now-brown-cow\n"
+ "Little-Miss-Muffett-sat-on-a-tuffet\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}