re = /^(?!(?:.*\-){5}).*/m
str = 'Hey-didle-didle-the-cat-and the fiddle
The-cow jumped over the-moon
How-now-brown-cow
Little-Miss-Muffett-sat-on-a-tuffet
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end