const regex = /^(?!(?:.*\-){5}).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(?:.*\\-){5}).*', 'gm')
const str = `Hey-didle-didle-the-cat-and the fiddle
The-cow jumped over the-moon
How-now-brown-cow
Little-Miss-Muffett-sat-on-a-tuffet
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}