$re = '/^(?!(?:.*\-){5}).*/m';
$str = 'Hey-didle-didle-the-cat-and the fiddle
The-cow jumped over the-moon
How-now-brown-cow
Little-Miss-Muffett-sat-on-a-tuffet
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);