using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https?:\/\/(www\.)?photos18\.com\/?((sort\/[\w\d]+)|(v\/[\w\d]+)|(cat\/\d)|)(\?.*)?";
string input = @"https://www.photos18.com/sort/likes?page=10
https://www.photos18.com/sort/likes
https://www.photos18.com/v/vNq0G
https://www.photos18.com/v/vNq0G?page=10&perpage=100
https://www.photos18.com/cat/1
https://www.photos18.com/cat/1?page=10
https://www.photos18.com/?page=10&perpage=100";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}