import re
regex = re.compile(r"^https?:\/\/(www\.)?photos18\.com\/?((sort\/[\w\d]+)|(v\/[\w\d]+)|(cat\/\d)|)(\?.*)?", flags=re.MULTILINE)
test_str = ("https://www.photos18.com/sort/likes?page=10\n"
"https://www.photos18.com/sort/likes\n"
"https://www.photos18.com/v/vNq0G\n"
"https://www.photos18.com/v/vNq0G?page=10&perpage=100\n"
"https://www.photos18.com/cat/1\n"
"https://www.photos18.com/cat/1?page=10\n"
"https://www.photos18.com/?page=10&perpage=100")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")