$re = '/^https?:\/\/(www\.)?photos18\.com\/?((sort\/[\w\d]+)|(v\/[\w\d]+)|(cat\/\d)|)(\?.*)?/m';
$str = 'https://www.photos18.com/sort/likes?page=10
https://www.photos18.com/sort/likes
https://www.photos18.com/v/vNq0G
https://www.photos18.com/v/vNq0G?page=10&perpage=100
https://www.photos18.com/cat/1
https://www.photos18.com/cat/1?page=10
https://www.photos18.com/?page=10&perpage=100';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);