import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*([A-Z0-9])\\1{3})[A-Z0-9]+$";
final String string = "1AAA23\n"
+ "2AAAA34\n"
+ "22A22B5\n"
+ "A222256\n"
+ "VN00000 \n"
+ "111123\n"
+ "1111AA\n"
+ "111AAA\n"
+ "1A";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}