use strict;
my $str = '1AAA23
2AAAA34
22A22B5
A222256
VN00000
111123
1111AA
111AAA
1A';
my $regex = qr/^(?!.*([A-Z0-9])\1{3})[A-Z0-9]+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}