re = /^(?!.*([A-Z0-9])\1{3})[A-Z0-9]+$/m
str = '1AAA23
2AAAA34
22A22B5
A222256
VN00000
111123
1111AA
111AAA
1A'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end