const regex = /^(?!.*([A-Z0-9])\1{3})[A-Z0-9]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*([A-Z0-9])\\1{3})[A-Z0-9]+$', 'gm')
const str = `1AAA23
2AAAA34
22A22B5
A222256
VN00000
111123
1111AA
111AAA
1A`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}