using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(\d+(?:\.\d+)?)](?::(?:\s*(\d+(?:\.\d+)?(?:,\d+(?:\.\d+)?)*))?)*";
string input = @"time sheets...""[8]: 27 The ending sm testing [21] [2222] [22], [222]:22:
square brackets with numbers inside e.g. [1] or [1111] or [1.2]
number 1 (above) followed by a colon e.g. [1]: or [1111]:
number 2 (above) followed by any length of numbers e.g. [111]:123
number 3 (above) followed by a space(s) and then numbers e.g. [111]: 27
[111]:29,28,100";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}