import re
regex = re.compile(r"\[(\d+(?:\.\d+)?)](?::(?:\s*(\d+(?:\.\d+)?(?:,\d+(?:\.\d+)?)*))?)*", flags=re.MULTILINE)
test_str = ("time sheets...\"[8]: 27 The ending sm testing [21] [2222] [22], [222]:22:\n\n"
"square brackets with numbers inside e.g. [1] or [1111] or [1.2]\n"
"number 1 (above) followed by a colon e.g. [1]: or [1111]:\n"
"number 2 (above) followed by any length of numbers e.g. [111]:123\n"
"number 3 (above) followed by a space(s) and then numbers e.g. [111]: 27\n\n"
"[111]:29,28,100")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")