use strict;
my $str = 'time sheets..."[8]: 27 The ending sm testing [21] [2222] [22], [222]:22:
square brackets with numbers inside e.g. [1] or [1111] or [1.2]
number 1 (above) followed by a colon e.g. [1]: or [1111]:
number 2 (above) followed by any length of numbers e.g. [111]:123
number 3 (above) followed by a space(s) and then numbers e.g. [111]: 27
[111]:29,28,100';
my $regex = qr/\[(\d+(?:\.\d+)?)](?::(?:\s*(\d+(?:\.\d+)?(?:,\d+(?:\.\d+)?)*))?)*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}