$re = '/\[(\d+(?:\.\d+)?)](?::(?:\s*(\d+(?:\.\d+)?(?:,\d+(?:\.\d+)?)*))?)*/m';
$str = 'time sheets..."[8]: 27 The ending sm testing [21] [2222] [22], [222]:22:
square brackets with numbers inside e.g. [1] or [1111] or [1.2]
number 1 (above) followed by a colon e.g. [1]: or [1111]:
number 2 (above) followed by any length of numbers e.g. [111]:123
number 3 (above) followed by a space(s) and then numbers e.g. [111]: 27
[111]:29,28,100';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);