#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d+)\s*-\s*EP.\s*(\d+)"
Local $sString = "MY TITLE OF STRING 5 - EP.2" & @CRLF & _
"MY TITLE OF STRING 6 - EP.3" & @CRLF & _
"" & @CRLF & _
"But in some cases this rule jump and and my string can become that way:" & @CRLF & _
"" & @CRLF & _
"MY TITLE OF STRING 5- EP.2" & @CRLF & _
"MY TITLE OF STRING 6-EP.3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")