using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)\s*-\s*EP.\s*(\d+)";
string input = @"MY TITLE OF STRING 5 - EP.2
MY TITLE OF STRING 6 - EP.3
But in some cases this rule jump and and my string can become that way:
MY TITLE OF STRING 5- EP.2
MY TITLE OF STRING 6-EP.3";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}