const regex = /(\d+)\s*-\s*EP.\s*(\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)\\s*-\\s*EP.\\s*(\\d+)', 'g')
const str = `MY TITLE OF STRING 5 - EP.2
MY TITLE OF STRING 6 - EP.3
But in some cases this rule jump and and my string can become that way:
MY TITLE OF STRING 5- EP.2
MY TITLE OF STRING 6-EP.3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}