import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)\\s*-\\s*EP.\\s*(\\d+)";
final String string = "MY TITLE OF STRING 5 - EP.2\n"
+ "MY TITLE OF STRING 6 - EP.3\n\n"
+ "But in some cases this rule jump and and my string can become that way:\n\n"
+ "MY TITLE OF STRING 5- EP.2\n"
+ "MY TITLE OF STRING 6-EP.3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}