#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?=[a-z0-9-]{1,52}$)[a-z0-9]+(?:-[a-z0-9]+){0,2}$"
Local $sString = "abc-123" & @CRLF & _
"abc-123-abc" & @CRLF & _
"" & @CRLF & _
"-abc-123" & @CRLF & _
"abc-123-" & @CRLF & _
"abc-123-abc-123" & @CRLF & _
"abc-12#-abc" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")