re = /^(?=[a-z0-9-]{1,52}$)[a-z0-9]+(?:-[a-z0-9]+){0,2}$/mi
str = 'abc-123
abc-123-abc
-abc-123
abc-123-
abc-123-abc-123
abc-12#-abc
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end