use strict;
my $str = 'abc-123
abc-123-abc
-abc-123
abc-123-
abc-123-abc-123
abc-12#-abc
';
my $regex = qr/^(?=[a-z0-9-]{1,52}$)[a-z0-9]+(?:-[a-z0-9]+){0,2}$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}