# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*\(^[0-9]*.[0-9]*.[0-9]*.[0-9]*\)\s-\s-\s\[\([0-9]*\\/[A-Z][a-z]*\\/[0-9]*\:[0-9]*\:[0-9]*\:[0-9]*\s\-[0-9]*\)]\s\"\([A-Z]*\s\)\\/[a-z]*\\/\s[A-Z]*\\/[0-9].[0-9]"\s\([0-9]*\s\).*/Ответ сервера: \4\nТип запроса: \3\nДата: \2\nIP-адрес: \1\n/g;t' <<< "127.0.0.1 - - [28/Jul/2006:10:27:32 -0300] \"GET /hidden/ HTTP/1.0\" 404 7218"