const regex = /.*\(^[0-9]*.[0-9]*.[0-9]*.[0-9]*\)\s-\s-\s\[\([0-9]*\/[A-Z][a-z]*\/[0-9]*\:[0-9]*\:[0-9]*\:[0-9]*\s\-[0-9]*\)]\s\"\([A-Z]*\s\)\/[a-z]*\/\s[A-Z]*\/[0-9].[0-9]"\s\([0-9]*\s\).*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\(^[0-9]*.[0-9]*.[0-9]*.[0-9]*\\)\\s-\\s-\\s\\[\\([0-9]*\\\/[A-Z][a-z]*\\\/[0-9]*\\:[0-9]*\\:[0-9]*\\:[0-9]*\\s\\-[0-9]*\\)]\\s\\"\\([A-Z]*\\s\\)\\\/[a-z]*\\\/\\s[A-Z]*\\\/[0-9].[0-9]"\\s\\([0-9]*\\s\\).*', 'g')
const str = `127.0.0.1 - - [28/Jul/2006:10:27:32 -0300] "GET /hidden/ HTTP/1.0" 404 7218`;
const subst = `Ответ сервера: \4\nТип запроса: \3\nДата: \2\nIP-адрес: \1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);