package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*\(^[0-9]*.[0-9]*.[0-9]*.[0-9]*\)\s-\s-\s\[\([0-9]*\/[A-Z][a-z]*\/[0-9]*\:[0-9]*\:[0-9]*\:[0-9]*\s\-[0-9]*\)]\s\"\([A-Z]*\s\)\/[a-z]*\/\s[A-Z]*\/[0-9].[0-9]"\s\([0-9]*\s\).*`)
var str = `127.0.0.1 - - [28/Jul/2006:10:27:32 -0300] "GET /hidden/ HTTP/1.0" 404 7218`
var substitution = "Ответ сервера: \4\nТип запроса: \3\nДата: \2\nIP-адрес: \1\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}