# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=y[^y]*)x/@/gm;t' <<< "A1xB2xC3yD4xE5xF6x"