const regex = /(?<=y[^y]*)x/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=y[^y]*)x', 'gm')
const str = `A1xB2xC3yD4xE5xF6x`;
const subst = `@`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);