$re = '/(?<=y[^y]*)x/m';
$str = 'A1xB2xC3yD4xE5xF6x';
$subst = "@";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;