use strict;
my $str = 'A1xB2xC3yD4xE5xF6x';
my $regex = qr/(?<=y[^y]*)x/mp;
my $subst = '@';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";