#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(\d+(?:\.5)? (?:US|UK|India|EU)) ?(\d+(?:\.5)? (?:US|UK|India|EU))? ?(\d+(?:\.5)? (?:US|UK|India|EU))? ?(\d+(?:\.5)? (?:US|UK|India|EU))?|((?:US|UK|India|EU) \d+(?:\.5)?) ?((?:US|UK|India|EU) \d+(?:\.5)?)? ?((?:US|UK|India|EU) \d+(?:\.5)?)? ?((?:US|UK|India|EU) \d+(?:\.5)?)?"
Local $sString = "a) " Adidas 8 India 9.5 UK Yellow sneakers" Must catch: "8 India" and "9.5 UK" Must not catch: "India 9.5"" & @CRLF & _
"" & @CRLF & _
"b) " Bata unisex sandals 44 Eu 10 uk light weight " Must catch: "44 Eu" and "10 uk" Must not catch: "Eu 10"" & @CRLF & _
"" & @CRLF & _
"c) " ABCD brand loafers for men 44.5 EU 8 India " Must catch: "44.5 EU" and "8 India" Must not catch: "EU 8""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")