const regex = /(\d+(?:\.5)? (?:US|UK|India|EU)) ?(\d+(?:\.5)? (?:US|UK|India|EU))? ?(\d+(?:\.5)? (?:US|UK|India|EU))? ?(\d+(?:\.5)? (?:US|UK|India|EU))?|((?:US|UK|India|EU) \d+(?:\.5)?) ?((?:US|UK|India|EU) \d+(?:\.5)?)? ?((?:US|UK|India|EU) \d+(?:\.5)?)? ?((?:US|UK|India|EU) \d+(?:\.5)?)?/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+(?:\\.5)? (?:US|UK|India|EU)) ?(\\d+(?:\\.5)? (?:US|UK|India|EU))? ?(\\d+(?:\\.5)? (?:US|UK|India|EU))? ?(\\d+(?:\\.5)? (?:US|UK|India|EU))?|((?:US|UK|India|EU) \\d+(?:\\.5)?) ?((?:US|UK|India|EU) \\d+(?:\\.5)?)? ?((?:US|UK|India|EU) \\d+(?:\\.5)?)? ?((?:US|UK|India|EU) \\d+(?:\\.5)?)?', 'gmi')
const str = `a) " Adidas 8 India 9.5 UK Yellow sneakers" Must catch: "8 India" and "9.5 UK" Must not catch: "India 9.5"
b) " Bata unisex sandals 44 Eu 10 uk light weight " Must catch: "44 Eu" and "10 uk" Must not catch: "Eu 10"
c) " ABCD brand loafers for men 44.5 EU 8 India " Must catch: "44.5 EU" and "8 India" Must not catch: "EU 8"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}