use strict;
my $str = 'a) " Adidas 8 India 9.5 UK Yellow sneakers" Must catch: "8 India" and "9.5 UK" Must not catch: "India 9.5"
b) " Bata unisex sandals 44 Eu 10 uk light weight " Must catch: "44 Eu" and "10 uk" Must not catch: "Eu 10"
c) " ABCD brand loafers for men 44.5 EU 8 India " Must catch: "44.5 EU" and "8 India" Must not catch: "EU 8"';
my $regex = qr/(\d+(?:\.5)? (?:US|UK|India|EU)) ?(\d+(?:\.5)? (?:US|UK|India|EU))? ?(\d+(?:\.5)? (?:US|UK|India|EU))? ?(\d+(?:\.5)? (?:US|UK|India|EU))?|((?:US|UK|India|EU) \d+(?:\.5)?) ?((?:US|UK|India|EU) \d+(?:\.5)?)? ?((?:US|UK|India|EU) \d+(?:\.5)?)? ?((?:US|UK|India|EU) \d+(?:\.5)?)?/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}