$re = '/(\d+(?:\.5)? (?:US|UK|India|EU)) ?(\d+(?:\.5)? (?:US|UK|India|EU))? ?(\d+(?:\.5)? (?:US|UK|India|EU))? ?(\d+(?:\.5)? (?:US|UK|India|EU))?|((?:US|UK|India|EU) \d+(?:\.5)?) ?((?:US|UK|India|EU) \d+(?:\.5)?)? ?((?:US|UK|India|EU) \d+(?:\.5)?)? ?((?:US|UK|India|EU) \d+(?:\.5)?)?/mi';
$str = 'a) " Adidas 8 India 9.5 UK Yellow sneakers" Must catch: "8 India" and "9.5 UK" Must not catch: "India 9.5"
b) " Bata unisex sandals 44 Eu 10 uk light weight " Must catch: "44 Eu" and "10 uk" Must not catch: "Eu 10"
c) " ABCD brand loafers for men 44.5 EU 8 India " Must catch: "44.5 EU" and "8 India" Must not catch: "EU 8"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);