# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*brown )(?:[^l]*)(.*)/\1\2/;t' <<< "The quick brown fox jumps over the lazy dog"